summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZajoe2020-12-09 21:31:21 +0200
committerZajoe2020-12-09 21:31:21 +0200
commit8293ab4d25d91941d88ed3c0ed9e725700b90ddf (patch)
treef2e67b10e7893b58f526e1ba803c444335492021 /PKGBUILD
downloadaur-8293ab4d25d91941d88ed3c0ed9e725700b90ddf.tar.gz
Add cctv-viewer registration to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17e3f22708b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Zajoe <zajoe223@gmail.com>
+_pkgname=cctv-viewer
+pkgname=${_pkgname}-git
+pkgver=0.1
+pkgrel=1
+epoch=0
+pkgdesc="A simple Qt application for simultaneously viewing multiple video streams. Designed for high performance and low latency. Based on ffmpeg."
+arch=('i686' 'x86_64')
+url="https://github.com/iEvgeny/cctv-viewer"
+license=('GPL')
+depends=('glibc'
+ 'gcc-libs'
+ 'qt5-base'
+ 'ffmpeg'
+ 'qt5-multimedia'
+ 'qt5-quickcontrols')
+makedepends=(git
+ make
+ cmake
+ qt5-tools)
+provides=(cctv-viewer)
+source=('git+https://github.com/iEvgeny/cctv-viewer.git'
+ 'git+https://github.com/iEvgeny/qmlav.git')
+sha1sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd $_pkgname
+ git submodule init
+ git config submodule.gmlav.url $srcdir/mysubmodule
+ git submodule update
+}
+
+build() {
+ cd $_pkgname
+ cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+
+package(){
+ make DESTDIR="$pkgdir" -C "$srcdir/$_pkgname" install
+ cd "$pkgdir"
+}
+