summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2015-06-26 15:06:28 +0200
committerRalf Mueller2015-06-26 15:06:28 +0200
commit8d7e6be8d90fee25addfaabcc7ba6fb2a08f1982 (patch)
tree272e16c91e93fccf8be0601f3b973f6c55f121f5 /PKGBUILD
downloadaur-8d7e6be8d90fee25addfaabcc7ba6fb2a08f1982.tar.gz
import to aur4 1.6.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b2c52c6f4d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
+pkg=cdi
+flavour=
+pkgname=${pkg}${flavour}
+pkgver=1.6.9
+fileID=10187
+pkgrel=0
+pkgdesc="CDI is a general purpose C-library for file IO in the geoscience area. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. CDI is the IO part of CDO"
+url="https://code.zmaw.de/projects/cdi"
+license="GPL"
+depends=('netcdf' 'grib_api')
+makedepends=('netcdf' 'grib_api')
+provides=()
+conflicts=()
+replaces=()
+arch=(i686 x86_64)
+backup=()
+install=
+source=(https://code.zmaw.de/attachments/download/${fileID}/${pkg}-${pkgver}.tar.gz)
+md5sums=('36e8edd67c96cd52c2ffcba4b7f4550f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --with-netcdf=/usr --with-grib_api=/usr CFLAGS=-fopenmp LIBS='-lpng -lopenjpeg'
+ make -j12 || return 1
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f $pkgdir/usr/bin/cdi
+}