summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2016-02-29 16:17:47 +0100
committerRalf Mueller2016-02-29 16:17:47 +0100
commit06cf6ee458165d29323728540b13a6f48646d804 (patch)
treeca228a2ab2fee74e5850ea017116b2b7e577bf73 /PKGBUILD
parentfa29d5adf1bbb4ac67d94f6e954a4b65af518195 (diff)
downloadaur-06cf6ee458165d29323728540b13a6f48646d804.tar.gz
update to cdo-1.7.1; add curl support, fix compile issue with patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94eb72cb44df..7fd6f5be60aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.7.0
-fileID=11392
+pkgver=1.7.1
+fileID=12070
pkgrel=0
pkgdesc="CDO is a collection of command line Operators to manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
-license="GPL"
-depends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw')
-makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw')
+license=('GPLv2')
+depends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl')
+makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl')
provides=()
conflicts=()
replaces=()
@@ -16,10 +16,11 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('cca30c3c79335ad734e1838806f7bfc2')
+md5sums=('f513a4bef1cf081cab3cfdc79d177bc5')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 <../../isnan.patch
./configure --prefix=/usr \
--with-netcdf=/usr \
--with-udunits2=/usr \
@@ -27,6 +28,7 @@ build() {
--with-szlib=/usr \
--with-proj=/usr \
--with-fftw3 \
+ --with-curl=/usr \
--with-grib_api=/usr \
CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " LIBS="-lpng -lopenjpeg"
make -j12 || return