summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2017-11-21 16:07:58 +0100
committerRalf Mueller2017-11-21 16:07:58 +0100
commit74a95a98a9f4ec6f84c93cb8569fc33a5392b07e (patch)
tree609f9b6157c1d2aa20a6c0869ddc128a64ff7dc2 /PKGBUILD
parent2772884ff1d6995c2e5273ea29b6a164dec08b00 (diff)
downloadaur-74a95a98a9f4ec6f84c93cb8569fc33a5392b07e.tar.gz
update to cdo-1.9.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0a77d521894..b6513d7c7c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.9.1
-fileID=15653
+pkgver=1.9.2
+fileID=16035
pkgrel=0
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
@@ -16,7 +16,7 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('e60a89f268ba24cee5c461f2c217829e')
+md5sums=('38e68d34f0b5b44a52c3241be6831423')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -28,12 +28,12 @@ build() {
--with-proj=/usr \
--with-fftw3 \
--with-curl=/usr \
- --with-grib_api=/usr \
+ --with-eccodes=/usr \
--with-magics=/usr \
--with-libxml2=/usr \
CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " \
CXXFLAGS="-g -O3 -std=c++11 -Wall -fopenmp -march=native " \
- LIBS="-leccodes -lhdf5 -ljasper -lpng -lopenjpeg" \
+ LIBS="-ljasper -lpng -lopenjpeg" \
CPPFLAGS="-I/usr/include/magics -I/usr/include/libxml2"
make -j12 || return