summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2017-04-13 12:36:17 +0200
committerRalf Mueller2017-04-13 12:36:17 +0200
commitb7a430e8c79bccdac78c53ccf4757e3eacc0e97b (patch)
treebc5f9687e7e29a2cb05245020ed766cbd28de8e2 /PKGBUILD
parent7064bd18e553809f843958dd7c95656cb7092d91 (diff)
downloadaur-b7a430e8c79bccdac78c53ccf4757e3eacc0e97b.tar.gz
new cdo release 1.8.1
use eccodes instead of grib_api
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea15f7ed988e..c58bbb4887c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
pkgname=cdo
-pkgver=1.8.0
-fileID=13772
+pkgver=1.8.1
+fileID=14271
pkgrel=0
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
license=('GPLv2')
-depends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
-makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
+depends=('netcdf' 'hdf5' 'proj' 'szip' 'eccodes' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
+makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'eccodes' 'udunits' 'fftw' 'curl' 'jasper' 'magics++')
provides=()
conflicts=()
replaces=()
@@ -16,7 +16,7 @@ arch=(i686 x86_64)
backup=()
install=
source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('42d4990a7c03159bc74335035273a59d')
+md5sums=('54498438de788f245d47499efad7966c')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -32,16 +32,10 @@ build() {
--with-magics=/usr \
--with-libxml2=/usr \
CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " \
- LIBS="-lhdf5 -ljasper -lpng -lopenjpeg" \
+ LIBS="-leccodes -lhdf5 -ljasper -lpng -lopenjpeg" \
CPPFLAGS="-I/usr/include/magics -I/usr/include/libxml2"
- make -j12 || return
-
-# ./configure --prefix=/usr --with-netcdf=/usr --with-udunits2=/usr
-# --with-hdf5=/usr --with-szlib=/usr --with-grib_api=/usr --with-magics=/usr
-# CFLAGS="-g -O3 -Wall -fopenmp -march=native $(pkg-config magics --cflags)
-# -std=gnu99" --with-libxml2 LIBS='-lpng -lopenjpeg -lstdc++'
-#
+ make -j12 || return
}
package() {