summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2021-05-10 11:26:53 +0200
committerRalf Mueller2021-05-10 11:26:53 +0200
commitcfc66067c382561b866a83752cde88f35e2c7f1c (patch)
treed4860a846180bce2d97c9fc8d509f239f1b792cf /PKGBUILD
parent43370dbb2c85fccca1eb1a166d2da1eabb48c41b (diff)
downloadaur-cfc66067c382561b866a83752cde88f35e2c7f1c.tar.gz
simplify flags for compiling and linking
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1d028de64de..5bc6c8bc91df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=cdo
pkgver=1.9.10
fileID=24638
-pkgrel=0
+pkgrel=1
pkgdesc="Command line tool manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
url="https://code.zmaw.de/projects/cdo"
license=('GPLv2')
@@ -31,10 +31,8 @@ build() {
--with-eccodes=/usr \
--with-magics=/usr \
--with-libxml2=/usr \
- CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
- CXXFLAGS="-g -O3 -std=c++11 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
- LIBS="-ljasper -lpng -lopenjpeg" \
- CPPFLAGS="-I/usr/include/magics -I/usr/include/libxml2"
+ CFLAGS="-g -O3 -Wall -fopenmp -march=native -ftree-vectorize -mavx2" \
+ CXXFLAGS="-g -O3 -Wall -fopenmp -march=native -ftree-vectorize -mavx2"
make -j12 || return
}