summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRalf Mueller2015-06-26 15:03:36 +0200
committerRalf Mueller2015-06-26 15:03:36 +0200
commitee013817b3bf84771e369b4251c8d52df28dd282 (patch)
tree421b774990b7e0d339c5a44f0f7a325b6c36e03d /PKGBUILD
downloadaur-ee013817b3bf84771e369b4251c8d52df28dd282.tar.gz
initial import for git-based cdo aut package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ecdebf3b920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Ralf Mueller <stark.dreamdetective@gmail.com>
+# Contributor: Ralf Mueller <stark.dreamdetective@gmail.com>
+pkgname=cdo
+pkgver=1.6.9
+fileID=10198
+pkgrel=1
+pkgdesc="CDO is a collection of command line Operators to manipulate and analyse Climate model Data. Supported data formats are GRIB, netCDF, SERVICE, EXTRA and IEG. There are more than 400 operators available."
+url="https://code.zmaw.de/projects/cdo"
+license="GPL"
+depends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw')
+makedepends=('netcdf' 'hdf5' 'proj' 'szip' 'grib_api' 'udunits' 'fftw')
+provides=()
+conflicts=()
+replaces=()
+arch=(i686 x86_64)
+backup=()
+install=
+source=(https://code.zmaw.de/attachments/download/${fileID}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('bf0997bf20e812f35e10188a930e24e2')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --with-netcdf=/usr \
+ --with-udunits2=/usr \
+ --with-hdf5=/usr \
+ --with-szlib=/usr \
+ --with-proj=/usr \
+ --with-fftw3 \
+ --with-grib_api=/usr \
+ CFLAGS="-g -O3 -std=gnu99 -Wall -fopenmp -march=native " LIBS="-lpng -lopenjpeg"
+ make -j12 || return
+
+
+# ./configure --prefix=/usr --with-netcdf=/usr --with-udunits2=/usr
+# --with-hdf5=/usr --with-szlib=/usr --with-grib_api=/usr --with-magics=/usr
+# CFLAGS="-g -O3 -Wall -fopenmp -march=native $(pkg-config magics --cflags)
+# -std=gnu99" --with-libxml2 LIBS='-lpng -lopenjpeg -lstdc++'
+#
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ rm -f $pkgdir/bin/cdotest
+}