summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Peukert2020-02-27 14:31:45 +0100
committerDaniel Peukert2020-02-27 14:31:45 +0100
commit91f7ec1e1886cf7ab4e50b198352328eee83617b (patch)
tree23f190df92898cdd6aa5fa812f1b96ef788262e7 /PKGBUILD
parent84b87a3dfdc0c20766601dd214346e2be754e877 (diff)
downloadaur-91f7ec1e1886cf7ab4e50b198352328eee83617b.tar.gz
Inlined launcher script and desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbdd4a4e98f7..c8d90eaa0ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,14 @@
pkgname='cecilia'
_reponame="${pkgname}5"
pkgver='5.4.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='Audio signal processing environment aimed at sound designers'
arch=('any')
url="http://ajaxsoundstudio.com/software/$pkgname"
license=('GPL3')
depends=('python' 'python-pyo>=1.0.1' 'python-numpy>=1.18' 'python-wxpython>=4.0.7')
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/belangeo/$_reponame/archive/$pkgver.tar.gz"
- "$pkgname.sh"
- "$pkgname.desktop"
-)
-sha256sums=('00c43539da73af982b136ab5ea6809ac9bb74188b05eb40d13428d13fe2ebef0'
- '0a17c0f9d4eb7195faaa99975628b610c821185f3ad712894029e5a135a54d4b'
- 'eea84108fe4117b0ac6841f3f22247c270373a0d825fedcf56e6626a734d1a8d')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::https://github.com/belangeo/$_reponame/archive/$pkgver.tar.gz")
+sha256sums=('00c43539da73af982b136ab5ea6809ac9bb74188b05eb40d13428d13fe2ebef0')
package() {
cd "$srcdir/$_reponame-$pkgver/"
@@ -25,9 +19,26 @@ package() {
install -Dm644 "${_reponame^}.py" "$pkgdir/$_libdir/${_reponame^}.py"
cp -r --no-preserve=ownership --preserve=mode 'Resources/' "$pkgdir/$_libdir/Resources/"
- install -Dm755 "../$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -dm755 "$pkgdir/usr/bin/"
+ cat << EOF > "$pkgdir/usr/bin/$pkgname"
+#!/bin/sh
+cd '/usr/lib/$pkgname'
+exec python '${_reponame^}.py' "\$@"
+EOF
+ chmod +x "$pkgdir/usr/bin/$pkgname"
+
+ install -dm755 "$pkgdir/usr/share/applications/"
+ cat << EOF > "$pkgdir/usr/share/applications/$pkgname.desktop"
+[Desktop Entry]
+Type=Application
+Name=${pkgname^}
+Comment=Audio signal processing environment aimed at sound designers
+Icon=$pkgname
+Exec=/usr/bin/$pkgname
+Terminal=false
+Categories=AudioVideo;Audio;
+EOF
- install -Dm644 "../$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
install -dm755 "$pkgdir/usr/share/pixmaps/"
ln -sf "/$_libdir/Resources/${_reponame^}.ico" "$pkgdir/usr/share/pixmaps/$pkgname.ico"
}