summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522023-10-13 09:13:31 +0200
committertytan6522023-10-13 09:13:31 +0200
commit382827ab0cae96a3f34c9168667c3425778f8e50 (patch)
tree12aed63d779fa79815969428bd62d36f479aa3d9 /PKGBUILD
parent3cbec5b23e26fefea68f1d19c9876a1e853fcc8d (diff)
downloadaur-382827ab0cae96a3f34c9168667c3425778f8e50.tar.gz
build: Fix libwebp patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a5b2bbd622f..83e220e5a8f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=cef-minimal-obs-bin
_cefver="103.0.0-5060-shared-textures_2594"
_version=${_cefver//-/_}
-_commit="c69ad37"
+_commit="17f8588"
_cefbranch="5060"
_chromiumver="103.0.${_cefbranch}.134"
_rebuild="1" # The tarball sometime can get rebuild by OBS Project
pkgver="${_version}+g${_commit}+chromium_${_chromiumver}_${_rebuild}"
pkgrel=1
+epoch=1
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/cef/tree/5060-shared-textures"
@@ -24,10 +25,10 @@ provides=("cef-minimal-obs=$pkgver")
conflicts=("cef-minimal-obs")
# Prevent people from using link time optimisation for this package because it make OBS unable to be built against it
options=('!lto' '!strip' 'debug')
-source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_x86_64_v2.tar.xz")
-source_aarch64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_aarch64_v2.tar.xz")
-sha256sums_x86_64=("4bee4c90edbdb67b889be28ba1c1558fa6b207ca01d921db9beab342873aa57d")
-sha256sums_aarch64=("c07ada8e18633308771d592d0313c6fb17d5805448e8921ebc51afb19e0e429e")
+source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_x86_64_v3.tar.xz")
+source_aarch64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_aarch64_v3.tar.xz")
+sha256sums_x86_64=("1253a6a36c3b8ac5b5ece9bfdb6eae6ab75e49516375fc475e2e871795ad9bea")
+sha256sums_aarch64=("66ebcfce94a4527c8dd085a685691d0c43291adab9f2be4f8a0762f4a614083a")
prepare() {
cd "${srcdir}/cef_binary_${_cefbranch}_linux_${CARCH}"