summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortytan6522023-03-25 20:08:41 +0100
committertytan6522023-03-25 20:08:41 +0100
commit603d9a277cc14d5921c7b687f82b2b61a972278a (patch)
tree1785d343d3497d8395b7786a74f05d0f7a34f287 /PKGBUILD
parentaa3660940fb7c631b054d505aae540b1a0f99f97 (diff)
downloadaur-603d9a277cc14d5921c7b687f82b2b61a972278a.tar.gz
build: Switch to xz archive and other stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 24 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f2cf06e8738..b2c9d7ce65cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,9 @@ _cefbranch="5060"
_chromiumver="103.0.${_cefbranch}.134"
_rebuild="1" # The tarball sometime can get rebuild by OBS Project
pkgver="${_version}+g${_commit}+chromium_${_chromiumver}_${_rebuild}"
-pkgrel=3
+pkgrel=4
pkgdesc="Chromium Embedded Framework minimal release needed by OBS Studio release in /opt/cef-obs"
-arch=("x86_64")
+arch=("x86_64" "aarch64")
url="https://github.com/obsproject/cef/tree/5060-shared-textures"
license=("BSD")
depends=("nss" "alsa-lib" "pango" "libxrandr" "libxcomposite"
@@ -20,25 +20,15 @@ provides=("cef-minimal-obs=$pkgver")
conflicts=("cef-minimal-obs")
# Prevent people from using link time optimisation for this package because it make OBS unable to be built against it
options=('!lto' '!strip' 'debug')
-source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux64.tar.bz2")
-sha256sums_x86_64=("ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d")
-
-# Kept for future-proofing, OBS now provide a custom CEF with some additions only for x86_64
-if [[ $CARCH == 'x86_64' ]]; then
- _arch=64
- _parch=x86_64
-elif [[ $CARCH == 'i686' ]]; then
- _arch=32
- _parch=x86
-elif [[ $CARCH == 'aarch64' ]]; then
- _arch=arm64
- _parch=arm64
-fi
+source_x86_64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_x86_64.tar.xz")
+source_aarch64=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux_aarch64.tar.xz")
+sha256sums_x86_64=("bf4aa9388bab7e94fa945cc3bba16b6da63b6a30f9c0342d42235468b39d84bf")
+sha256sums_aarch64=("68d915c9ba2639cba762a54cd3430fce2527aa6355d831d3cfcb6157664206b0")
prepare() {
- cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
+ cd "${srcdir}/cef_binary_${_cefbranch}_linux_${arch}"
- # Fix permissions
+ # Fix folder permissions
chmod 755 Release
chmod 755 Resources
chmod 755 Resources/locales
@@ -52,23 +42,31 @@ prepare() {
chmod 755 include/test
chmod 755 include/views
chmod 755 include/wrapper
+ chmod 755 libcef_dll
+ chmod 755 libcef_dll/base
+ chmod 755 libcef_dll/cpptoc
+ chmod 755 libcef_dll/cpptoc/test
+ chmod 755 libcef_dll/cpptoc/views
+ chmod 755 libcef_dll/ctocpp
+ chmod 755 libcef_dll/ctocpp/test
+ chmod 755 libcef_dll/ctocpp/views
+ chmod 755 libcef_dll/wrapper
# Remove pre-built wrapper
rm -rf build
}
build() {
- cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
+ cd "${srcdir}/cef_binary_${_cefbranch}_linux_${arch}"
- #The arm64 CEF set the wrong arch for the project
cmake \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DPROJECT_ARCH=$_parch .
+ -DPROJECT_ARCH=$arch .
make libcef_dll_wrapper
- # Remove unneeded generated files
- rm -f CMakeCache.txt Makefile cmake_install.cmake
+ # Remove unneeded files
+ rm -f CMakeLists.txt CMakeCache.txt Makefile cmake_install.cmake README.txt libcef_dll/CMakeLists.txt
rm -rf CMakeFiles
cd libcef_dll_wrapper
@@ -78,8 +76,8 @@ build() {
package() {
mkdir -p "$pkgdir"/opt/cef-obs/
- cp -a "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}/* "$pkgdir"/opt/cef-obs
- rm -f "$pkgdir"/opt/cef-obs/CMakeLists.txt "$pkgdir"/opt/cef-obs/LICENSE.txt "$pkgdir"/opt/cef-obs/README.txt
+ cp -a "${srcdir}/cef_binary_${_cefbranch}_linux_${arch}"/* "$pkgdir"/opt/cef-obs
+ rm -f "$pkgdir"/opt/cef-obs/LICENSE.txt
rm -rf "$pkgdir"/opt/cef-obs/cmake
- install -Dm644 "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}/LICENSE.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 "${srcdir}/cef_binary_${_cefbranch}_linux_${arch}/LICENSE.txt" "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}