summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2017-11-03 01:11:05 +0100
committerCarsten Teibes2017-11-03 01:11:05 +0100
commitc908e33ed25178ca7fd353c5962519f5531e5d24 (patch)
tree8ca8b6bec9ce7e89b28e4565761ec003da48cb98 /PKGBUILD
parent047f6efd30c524b6a4900b9ad03b575e5a135f5b (diff)
downloadaur-cegui-0.7.tar.gz
[fix] compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 587d94ceee2b..d8d58272374d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,34 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
# Contributor: josephgbr <rafael.f.f1@gmail.com>
-# based on cegui from Arch Linux repository, original credits go to:
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
-# Contributor: Juergen Hoetzel <juergen@archlinux.org>
-# Contributor: William Rea <sillywilly@gmail.com>,
-# Contributor: Bjorn Lindeijer <bjorn@lindeijer.nl>
-
pkgname=cegui-0.7
pkgver=0.7.9
-pkgrel=4
+pkgrel=5
pkgdesc="A free library providing windowing and widgets for graphics APIs/engines (legacy version)"
arch=('i686' 'x86_64')
-url="http://crayzedsgui.sourceforge.net"
+url="http://cegui.org.uk"
license=("MIT")
-depends=('glew' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51' 'silly' 'mesa' 'glm' 'glfw')
-makedepends=('python2' 'doxygen' 'gtk2' 'boost' 'graphviz') # 'ogre' 'irrlicht')
+depends=('glew' 'freetype2' 'libxml2' 'devil' 'freeglut' 'lua51' 'silly' 'mesa' 'glm' 'glfw' 'freeimage')
+makedepends=('python2' 'doxygen' 'gtk2' 'boost' 'graphviz')
optdepends=("python2: python bindings"
- "boost-libs: null renderer with python2"
- #"ogre: ogre module"
- #"irrlicht: irrlicht module"
+ "boost-libs: renderer with python2"
"gtk2: gtk2 module")
-provides=('cegui')
conflicts=('cegui')
-options=('!libtool')
-source=("http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz")
-sha256sums=('7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c')
+source=("http://downloads.sourceforge.net/crayzedsgui/CEGUI-$pkgver.tar.gz"
+ "$pkgname-compilation-fix.diff")
+sha256sums=('7c3b264def08b46de749c2acaba363e907479d924612436f3bd09da2e474bb8c'
+ '95b747470a2419bc9d0df7ade7d45ef0acb694609172d3b4110c1836b256ca39')
+
+prepare() {
+ patch -Np0 < $pkgname-compilation-fix.diff
+}
build() {
cd CEGUI-$pkgver
./bootstrap
- Lua_CFLAGS="$(pkg-config --cflags lua5.1)" \
- Lua_LIBS="$(pkg-config --libs lua5.1)" \
+ Lua_CFLAGS="$(pkg-config --cflags lua51)" \
+ Lua_LIBS="$(pkg-config --libs lua51)" \
PYTHON="/usr/bin/python2" ./configure --prefix=/usr --sysconfdir=/etc \
--enable-null-renderer --with-gtk2 --disable-samples \
--disable-ogre-renderer --disable-irrlicht-renderer