summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNoa2024-03-17 22:29:15 -0500
committerNoa2024-03-17 22:30:25 -0500
commit204b3803bd1c692b11b1b3ec0386073cdb2bb37c (patch)
tree2bcd592692ba7471c6923a658dc8b9500ff8550e /PKGBUILD
parente9779d77df1107cebe8215bf25a3acb532c61d2a (diff)
downloadaur-204b3803bd1c692b11b1b3ec0386073cdb2bb37c.tar.gz
Add !debug option and license and aarch64 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba9063d55146..f7a284b0345e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
# Maintainer: Noa <coolreader18@gmail.com>
pkgname=celeste64-bin
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A game made in under 2 weeks for Celeste's 6th Anniversary (official bin)"
-arch=(x86_64)
+arch=(x86_64 aarch64)
url="https://maddymakesgamesinc.itch.io/celeste64"
license=('custom:celeste64')
-options=('!strip')
+options=('!strip' '!debug')
provides=(celeste64)
conflicts=(celeste64)
-_archive_file="Celeste64-v$pkgver-Linux-x64.zip"
-source=("https://github.com/ExOK/Celeste64/releases/download/v$pkgver/$_archive_file"
+source_x86_64=(Celeste64-$pkgver-x86_64.zip::"https://github.com/ExOK/Celeste64/releases/download/v$pkgver/Celeste64-v$pkgver-Linux-x64.zip")
+source_aarch64=(Celeste64-$pkgver-aarch64.zip::"https://github.com/ExOK/Celeste64/releases/download/v$pkgver/Celeste64-v$pkgver-Linux-arm64.zip")
+source=("https://github.com/ExOK/Celeste64/raw/v$pkgver/ReadMe.md"
+ SourceLicense.txt::"https://github.com/ExOK/Celeste64/raw/v$pkgver/Source/License.txt"
"celeste64.desktop")
-noextract=("$_archive_file")
-sha256sums=('56720256950cdeba9bb6eef9bdd3abdb85362c1ab949b8b183ad88c5db416cad'
+noextract=("Celeste64-$pkgver-"{x86_64,aarch64}".zip")
+sha256sums_x86_64=('56720256950cdeba9bb6eef9bdd3abdb85362c1ab949b8b183ad88c5db416cad')
+sha256sums_aarch64=('b871fd37759e2ab1187b78fa93e99407c69c72949e21993447068017f09c002d')
+sha256sums=('e553c30d574acd1a7f768f3e952fb167e4a05fcfa824bdccf1888a39e21f3069'
+ '45aa2d76c41f60e8062b2c4a8f1014ed8a2601ca51432bd9436e58bc8fa0f640'
'9906284626f846e34c55807a60126b2bf034697adab5ef15c2665e18f5abd795')
package() {
+ cd "$srcdir"
mkdir -p "$pkgdir"/opt/celeste64
- bsdtar -xC "$pkgdir"/opt/celeste64 -f "$_archive_file"
+ bsdtar -xC "$pkgdir"/opt/celeste64 -f "Celeste64-$pkgver-$CARCH.zip"
install -Dm 644 celeste64.desktop -t "$pkgdir"/usr/share/applications
+ awk '/License/{license=1} license{print}' ReadMe.md >License.txt
+ install -Dm 644 License.txt -t "$pkgdir"/usr/share/licenses/celeste64
+ install -Dm 644 SourceLicense.txt -t "$pkgdir"/usr/share/licenses/celeste64
}