summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMika Hyttinen2023-01-26 14:34:23 +0200
committerMika Hyttinen2023-01-26 14:34:23 +0200
commit6b1cf47279f398f6342faf563c5568414cd61727 (patch)
treedd776c909e5b4b9d870ccf9f61e68baef00fcdde /PKGBUILD
downloadaur-6b1cf47279f398f6342faf563c5568414cd61727.tar.gz
First push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6bfc58b6f9ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Mika Hyttinen <mika.hyttinen@gmail.com>
+pkgname=cellframe-dashboard
+pkgver=2.10.19
+pkgrel=1
+pkgdesc="Super application for managing Cellframe node"
+arch=('x86_64' 'aarch64')
+url="https://cellframe.net"
+license=('GPL3')
+depends=(cellframe-node qt5-graphicaleffects qt5-base qt5-quickcontrols2 qt5-quickcontrols2)
+makedepends=(git qt5-base qt5-declarative)
+options=()
+source=(git+https://gitlab.demlabs.net/cellframe/$pkgname.git#commit=04b16557332a61347879ca062c44adb64b185d3f)
+md5sums=('SKIP')
+install=$pkgname.install
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ cat << EOF > .gitmodules
+[submodule "cellframe-ui-sdk"]
+ path = cellframe-ui-sdk
+ url = https://gitlab.demlabs.net/cellframe/cellframe-ui-sdk.git
+ branch = master
+[submodule "dap-ui-sdk"]
+ path = dap-ui-sdk
+ url = https://gitlab.demlabs.net/dap/dap-ui-sdk
+ branch = master
+[submodule "prod_build"]
+ path = prod_build
+ url = https://gitlab.demlabs.net/cellframe/prod_build_cellframe-dashboard
+ branch = master
+[submodule "cellframe-node"]
+ path = cellframe-node
+ url = https://gitlab.demlabs.net/cellframe/cellframe-node
+ branch = master
+EOF
+ git submodule sync
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ sed -i 's|CellFrameNode||g' CellFrameDashboard.pro
+ head -n -2 CellFrameDashboard.pro | tee CellFrameDashboard.pro
+ qmake-qt5
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -Dm 644 "$pkgdir/opt/$pkgname/share/CellFrameDashboard.desktop" -t "$pkgdir/usr/share/applications/" || return 1
+
+ install -Dm 644 "$pkgdir/opt/$pkgname/share/init.d/$pkgname.service" -t "$pkgdir/usr/lib/systemd/system/" || return 1
+
+ install -Dm 644 "$srcdir/$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname" || return 1
+
+}