summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchris_l2017-12-13 20:51:32 -0600
committerchris_l2017-12-13 20:52:33 -0600
commitb7670d37c89b021067df4d60a54c235a64528166 (patch)
tree615488986e1699ed8ebec01be8109b18702f6f6f /PKGBUILD
downloadaur-b7670d37c89b021067df4d60a54c235a64528166.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a44fafcdb67e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Contributor: chris_L <chrislcenter dash mamoru at yahoo.com dot mx>
+
+pkgname=cemu
+pkgver=1.11.1
+pkgrel=1
+pkgdesc="Wii U emulator (via wine). Includes the Cemuhook plugin and graphic packs"
+arch=(x86_64)
+url="http://cemu.info/"
+license=('custom')
+depends=('wine')
+source=(
+ cemu.sh
+ cemu.xpm
+ cemu.desktop
+ http://cemu.info/releases/cemu_1.11.1.zip
+ https://files.sshnuke.net/cemuhook_1112_0554.zip
+ https://github.com/slashiee/cemu_graphic_packs/releases/download/appveyor484/graphicPacks_2-484.zip
+)
+noextract=('cemuhook_1112_0554.zip'
+ 'graphicPacks_2-484.zip')
+install=${pkgname}.install
+
+md5sums=('01118cf3e1ef9e453b5c56d2d27f6967'
+ '54d70005a8975812ab54fcfef53f7bde'
+ '315e8156c71df6b229acf7472f46568f'
+ '6430f06383c530fc0ac76d9ba8f23931'
+ '497385d69e68bc60eac8263ea75c87f4'
+ '5896506daed6a55e2ab3010020e0c70b')
+
+options=(!strip)
+
+build() {
+ cd $srcdir/
+ cd cemu_$pkgver
+ bsdtar -x -f ../../cemuhook_1112_0554.zip
+ cd graphicPacks
+ bsdtar -x -f ../../../graphicPacks_2-484.zip
+}
+package() {
+ cd $srcdir
+ install -d -m755 $pkgdir/usr/share/
+ install -d -m755 $pkgdir/usr/share/$pkgname
+ install -d -m755 $pkgdir/usr/bin
+ install -m755 cemu.sh $pkgdir/usr/bin/$pkgname
+ install -d -m755 $pkgdir/usr/share/applications
+ install -d -m755 $pkgdir/usr/share/pixmaps
+ install -m644 cemu.desktop $pkgdir/usr/share/applications
+ install -m644 cemu.xpm $pkgdir/usr/share/pixmaps/cemu.xpm
+ cd cemu_$pkgver
+ install -m644 Cemu.exe $pkgdir/usr/share/$pkgname
+ install -m644 dbghelp.dll $pkgdir/usr/share/$pkgname
+ install -m644 keystone.dll $pkgdir/usr/share/$pkgname
+ cp -R gameProfiles $pkgdir/usr/share/$pkgname
+ cp -R graphicPacks $pkgdir/usr/share/$pkgname
+ cp -R hfiomlc01 $pkgdir/usr/share/$pkgname
+ cp -R mlc01 $pkgdir/usr/share/$pkgname
+ cp -R shaderCache $pkgdir/usr/share/$pkgname
+ find $pkgdir/usr/share/$pkgname -type f -exec chmod 644 {} \;
+ find $pkgdir/usr/share/$pkgname -type d -exec chmod 755 {} \;
+}
+