summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Żok2019-10-09 15:18:17 +0200
committerTomasz Żok2019-10-09 15:18:17 +0200
commit55fad8bfb4dbd761753205775daf17344a1316d3 (patch)
tree4ad1fa3f04474830f7b39df9e93447450fdd9276 /PKGBUILD
parent3e554515849e0c33cd802e75d07d1ed87dfaf778 (diff)
downloadaur-centroid-rna-package.tar.gz
CentroidFold 0.0.16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 544349f299c7..40ca81b9b750 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
pkgname=centroid-rna-package
-pkgver=0.0.15
-pkgrel=2
+pkgver=0.0.16
+pkgrel=1
pkgdesc="CentroidFold for predicting RNA secondary structures"
arch=('i686' 'x86_64')
url="https://github.com/satoken/centroid-rna-package"
license=('GPL')
-depends=('boost-libs>=1.40.0')
-makedepends=('viennarna>=1.8')
+depends=('boost-libs>=1.40.0' 'mpfr')
+makedepends=('viennarna>=1.8' 'pkgconf')
source=("https://github.com/satoken/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('dc333b18b7f4d353d667fe66d66404ba')
+md5sums=('0978870363a832bb9875c5114e37f79c')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --with-vienna-rna
+ cd "$pkgname-$pkgver"
+ LIBS=$(pkg-config --libs mpfr) ./configure --prefix=/usr --with-vienna-rna
make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}