summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBazaah2024-08-04 21:54:38 +0000
committerBazaah2024-08-04 22:16:08 +0000
commit879e51222e364eba6b448ec9edb50c18d151b298 (patch)
treea8e2aacc61bc497971a5bfd450c9e32fb15c6601 /PKGBUILD
parent90b4dfad619261e5c6f6129a070819d03beddb54 (diff)
downloadaur-879e51222e364eba6b448ec9edb50c18d151b298.tar.gz
pkgbuild: add pkg.ceph-node-proxy
This is seemingly something to do with cephadm and (Dell?) hardware metrics using the RedFishAPI... api. Apparently it was split out because the upstream 'needed' it in v18 but the rest of the changes around it from v19 weren't going to be backported. Seems fairly worthless for ArchLinux but who can say. References: https://github.com/ceph/ceph/commit/e1630fb8fcfa4460306b5e506c6a436f68c505a8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89bbf74b0567..a546be05dd9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url='https://ceph.com/'
arch=('x86_64')
license=('GPL')
pkgname=(
- ceph-{common,compressor,crypto,erasure,tools,test,volume,cephadm}
+ ceph-{common,compressor,crypto,erasure,tools,test,volume,cephadm,node-proxy}
ceph-{rados,base,mon,mgr,osd,mds,rbd,cephfs,rgw}
lib{rados,cephfs,rbd,rgw,cephsqlite}
python-{ceph-common,rados,rbd,cephfs,rgw}
@@ -557,6 +557,11 @@ _make_ceph_packages() {
$bin/cephfs-top \
$python/cephfs_top-*
+ _package ceph-node-proxy \
+ $bin/ceph-node-proxy \
+ $python/ceph_node_proxy \
+ $python/ceph_node_proxy-*egg-info*
+
###############################################
# Ceph misc. utils #
###############################################
@@ -827,6 +832,7 @@ package_ceph-osd() {
)
optdepends=(
'ceph-volume: For preparing block devices for OSD daemons'
+ 'ceph-node-proxy: For RedFishAPI hardware metrics'
'smartmontools: disk monitoring via S.M.A.R.T'
'nvme-cli: disk monitoring for NVMe drives'
)
@@ -1010,6 +1016,16 @@ package_cephfs-top() {
_print
}
+package_ceph-node-proxy() {
+ pkgdesc='Ceph Storage daemon for cephadm deployments to collect RedFishAPI hardware metrics'
+ depends=(
+ 'python'
+ )
+
+ mv __pkg__/$pkgname/* "$pkgdir"
+ _print
+}
+
package_ceph-cephadm() {
pkgdesc='Ceph Storage adminstration and configuration utility'
provides=('cephadm')