summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBazaah2023-05-06 17:50:09 +0000
committerBazaah2023-09-09 17:04:20 +0000
commitbf7fef77fc2536078c1def8017f9031c42546ac8 (patch)
tree35951a6c49557c8adedb90c13c151b8bf244cdcd /PKGBUILD
parenteb35c47a510ba0f79ef8f9195bb5ac8bcde00ca8 (diff)
downloadaur-bf7fef77fc2536078c1def8017f9031c42546ac8.tar.gz
pkgbuild: package misc. ceph tooling / libs
These are mostly used by the upstream development team for interacting with various internals of the cluster and live tests. However, the impetus for this entire patchset also lurks: java-cephfs. A package that requires we pull in the entire java runtime, likely for a package absolutely no one uses. Good riddance. - ceph-tools - ceph-test - java-cephfs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 72 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5efc3294466..342a43056de9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -494,6 +494,36 @@ _make_ceph_packages() {
$python/cephfs_top-*
###############################################
+ # Ceph misc. utils #
+ ###############################################
+
+ _package ceph-tools \
+ $bin/ceph-post-file \
+ $bin/ceph-dedup-tool \
+ $bin/ceph-erasure-code-tool \
+ $bin/ceph-kvstore-tool \
+ $bin/ceph-debugpack \
+ $bin/ceph-dencoder \
+ $man/man8/ceph-{post-file,dencoder}.8 \
+ $man/man8/ceph-{debugpack,kvstore-tool}.8
+
+ _package ceph-test \
+ $bin/ceph_perf_local \
+ $bin/ceph_perf_msgr_client \
+ $bin/ceph_perf_msgr_server \
+ $bin/ceph_erasure_code_benchmark \
+ $bin/ceph_objectstore_bench \
+ $bin/ceph_bench_log \
+ $bin/ceph_perf_objectstore \
+ $bin/ceph_omapbench \
+ $bin/ceph-syn \
+ $man/man8/ceph-syn.8
+
+ _package java-cephfs \
+ $lib/libcephfs_jni.so{,.1,.1.0.0} \
+ $share/java/libcephfs.jar
+
+ ###############################################
# Ceph python packages #
###############################################
@@ -934,6 +964,48 @@ package_ceph-cephadm() {
}
###############################################
+# Ceph misc. utils #
+###############################################
+
+package_ceph-tools() {
+ pkgdesc='Ceph Storage miscellaneous tooling and utilities'
+ depends=(
+ "ceph-base=${__version}"
+
+ 'bash' 'boost-libs' 'gperftools' 'libaio' 'libcap'
+ 'snappy'
+ )
+
+ mv __pkg__/$pkgname/* "$pkgdir"
+ _print
+}
+
+package_ceph-test() {
+ pkgdesc='Ceph Storage tools for benchmarking and testing live clusters'
+ depends=(
+ "ceph-base=${__version}"
+
+ 'libcap' 'libaio' 'boost-libs' 'fmt' 'gperftools'
+ 'snappy'
+ )
+
+ mv __pkg__/$pkgname/* "$pkgdir"
+ _print
+}
+
+package_java-cephfs() {
+ pkgdesc='Ceph Storage JNI bindings for CephFS'
+ depends=(
+ "libcephfs=${__version}"
+
+ 'java-runtime'
+ )
+
+ mv __pkg__/$pkgname/* "$pkgdir"
+ _print
+}
+
+###############################################
# Ceph python packages #
###############################################