summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Benge2019-03-09 00:31:08 -0700
committerJustin Benge2019-03-09 00:31:08 -0700
commitb550c2fbc3dd6f4458839900a14cc963f20baea1 (patch)
treea730a9fe4e76d0b686e3a44d7ab4f5f6eeb92631 /PKGBUILD
downloadaur-ceph-deploy-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac7ccf4f0a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Justin Benge <justinbng36@gmail.com>
+pkgname=ceph-deploy-git
+_pkgname=ceph-deploy
+pkgver=r2063.e5831d6
+pkgrel=1
+pkgdesc="Automation tool for ceph file cluster"
+arch=("any")
+url="https://github.com/ceph/ceph-deploy.git"
+license=('MIT')
+depends=('python-setuptools' 'python-execnet')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/ceph/ceph-deploy.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd $_pkgname
+ python setup.py build
+}
+
+package() {
+ cd $_pkgname
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}