summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Lange2016-06-05 22:36:59 +0200
committerJohannes Lange2016-06-05 22:41:48 +0200
commite9dc90ccd7ded478b75bc68b98974abdf403d716 (patch)
tree8eba51840f1a57928bddf4217eee84717ce3dd03 /PKGBUILD
parent1c7226a33c72be69f31e50a57e600e6b0ee04928 (diff)
downloadaur-e9dc90ccd7ded478b75bc68b98974abdf403d716.tar.gz
inluding appropriate version oflibqtkeychain-qt4 and using a wrapper
script setting LD_LIBRARY_PATH
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 30 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ff0f571dd3c..258673e923da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,60 @@
# Maintainer: Johannes Lange (<firstname>DOT<lastname>ATcern.ch>)
pkgname=cernbox
pkgver=1.7.2_3.1
-pkgrel=2
+pkgrel=3
pkgdesc="Synchronization client for CERN's CERNBox cloud service (based on ownCloud)"
arch=('i686' 'x86_64')
url="http://cernbox.web.cern.ch/"
license=('GPL')
-depends=('neon' 'qtwebkit' 'qtkeychain')
+depends=('neon' 'qtwebkit')
provides=('ocsync' 'cernboxsync')
if [ "$CARCH" = "i686" ]; then
source=(
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/cernbox-client-${pkgver/_/-}.i586.rpm
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/libcernboxsync0-${pkgver/_/-}.i586.rpm
+ http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/i586/libqtkeychain0-0.4-8.1.i586.rpm
+ cernbox
+ cernboxcmd
+ )
+ md5sums=(
+ '6e81d85f032302cb135c108f8b02a9c5'
+ 'd00a13e8e6e032970fc6b34a7aa81be9'
+ 'a013910e30cf66b5b113c47ee0b895fc'
+ '911d014c0670d3bf7cbc622f00206339'
+ '83a60fef4c5f69b2ed91605db490a955'
)
- md5sums=('6e81d85f032302cb135c108f8b02a9c5'
- 'd00a13e8e6e032970fc6b34a7aa81be9')
elif [ "$CARCH" = "x86_64" ]; then
source=(
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/cernbox-client-${pkgver/_/-}.x86_64.rpm
http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libcernboxsync0-${pkgver/_/-}.x86_64.rpm
+ http://cernbox-resources.web.cern.ch/cernbox-resources/Linux/repo/openSUSE_13.2/x86_64/libqtkeychain0-0.4-8.1.x86_64.rpm
+ cernbox
+ cernboxcmd
+ )
+ md5sums=(
+ '68110fa2ae3ad0e973e46337784c00ff'
+ 'e5c4c22cbed3962950ae5af93d328afa'
+ '292f7710439c7a272acf16091be69ae4'
+ '911d014c0670d3bf7cbc622f00206339'
+ '83a60fef4c5f69b2ed91605db490a955'
)
- md5sums=('68110fa2ae3ad0e973e46337784c00ff'
- 'e5c4c22cbed3962950ae5af93d328afa')
fi
package() {
cp -dpr "${srcdir}/usr" "${pkgdir}"
cp -dpr "${srcdir}/etc" "${pkgdir}"
- mkdir "${pkgdir}/usr/share/pixmaps"
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
cp "${pkgdir}/usr/share/icons/hicolor/128x128/apps/cernbox.png" "${pkgdir}/usr/share/pixmaps"
if [ "$CARCH" = "x86_64" ]; then
mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"
fi
+ mv "${pkgdir}/usr/bin/cernbox" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/bin/cernboxcmd" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/lib/libqtkeychain.so.0" "${pkgdir}/usr/lib/cernbox/"
+ mv "${pkgdir}/usr/lib/libqtkeychain.so.0.4.0" "${pkgdir}/usr/lib/cernbox/"
+ # wrapper scripts
+ cp -p "${srcdir}/cernbox" "${pkgdir}/usr/bin"
+ cp -p "${srcdir}/cernboxcmd" "${pkgdir}/usr/bin"
}