summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBruno Pagani2017-01-10 22:55:38 +0100
committerBruno Pagani2017-01-10 22:55:38 +0100
commitf0405837202857cf65ebb793ef4d6e275bde7d56 (patch)
tree86677c900f3d69874b23564a538fbe4a76220ade /PKGBUILD
parentaff3186f3aaab7780bffc2050716644c569ec508 (diff)
downloadaur-f0405837202857cf65ebb793ef4d6e275bde7d56.tar.gz
Enhancements suggested by anthraxx
Use --optimize=1 Use --skip-build Also add systemd which was a missing dependency regarding the .install file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21058b6c8b03..7f4a6caef0d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=certbot
pkgname=${_pkgname}-user
pkgver=0.9.3
-pkgrel=1
+pkgrel=2
pkgdesc="Let’s Encrypt certbot running as certbot user rather than root, with either standalone or webroot mode."
arch=('any')
license=('Apache')
@@ -14,7 +14,7 @@ depends=('ca-certificates' "python2-acme=${pkgver}" 'python2-configargparse' 'py
'python2-cryptography' 'python2-pyopenssl' 'python2-mock' 'python2-parsedatetime'
'python2-psutil' 'python2-pyrfc3339' 'python2-pythondialog' 'python2-pytz'
'python2-requests' 'python2-setuptools' 'python2-six' 'python2-zope-component'
- 'python2-zope-interface')
+ 'python2-zope-interface' 'systemd')
checkdepends=('python2-nose')
conflicts=('certbot')
provides=('certbot')
@@ -41,7 +41,7 @@ check() {
package() {
cd ${_pkgname}-${pkgver}
- python2 setup.py install --root="${pkgdir}"
+ python2 setup.py install --root="${pkgdir}" --skip-build --optimize=1
install -Dm644 "${srcdir}"/${_pkgname}.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/${_pkgname}.conf
install -Dm644 "${srcdir}"/${_pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${_pkgname}.conf