summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuba Serafinowski2013-11-14 22:32:19 +0200
committerKuba Serafinowski2013-11-14 22:32:19 +0200
commit1605ac6066c7d0e354e50ac408346100d5e0fda2 (patch)
treee7580199f91740f181f20bdd23b8853ec1477e0f /PKGBUILD
parent2b18a11be16e4bbb21ba1510bfc6a7e71df2277c (diff)
downloadaur-1605ac6066c7d0e354e50ac408346100d5e0fda2.tar.gz
cfengine: lots of changes and 3.5.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 30 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83bd91d75f6..73e096a495b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,25 @@
-# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
-# http://github.com/fukawi2/aur-packages
+# Maintainer: Kuba Serafinowski <zizzfizzix AT gmail DOT com>
+# https://github.com/zizzfizzix/pkgbuilds
+#
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
# Contributor: Christian Berendt <christian@thorlin.de>
-### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
-### Please ask support questions about this software in one of:
-### 1) The AUR comments; OR
-### 2) Upstream forums/maillist etc; OR
-### 3) The ArchLinux forums
-### I do not always know enough about the software itself, or don't have the
-### time to promptly respond to direct emails.
-### If you have found a problem with the package/PKGBUILD (as opposed to
-### the software) then please do email me or post an AUR comment.
-
pkgname=cfengine
-pkgver=3.5.0
-pkgrel=2
-pkgdesc="automated suite of programs for configuring and maintaining Unix-like computers."
-url="http://www.cfengine.org"
+pkgver=3.5.2
+pkgrel=1
+pkgdesc='Automated suite of programs for configuring and maintaining Unix-like computers.'
+url='http://www.cfengine.org'
license=('GPL3')
+options=('!libtool')
arch=('i686' 'x86_64')
-# depends on a bunch of things because of specific bundles, should be
-# modular! Trying to have as little here as possible
-depends=('qdbm' 'openssl' 'pcre' 'acl' 'libxml2')
-# do not depend on things which are not packages, only in AUR, sadly qdbm
-# is required (as one of them is required)
-# also libvirt makes sence for hosting servers, but not applicances (it
-# has far too many dependencies on X11 libraries)
-# database support is considered optional, enable if needed
+depends=('qdbm' 'openssl' 'pcre' 'libxml2')
optdepends=('tokyocabinet' 'libvirt' 'postgresql-libs' 'libmariadbclient')
-
-source=(
- "${pkgname}-${pkgver}.tar.gz::http://cfengine.com/source-code/download?file=${pkgname}-${pkgver}.tar.gz"
- "cf-execd.service"
- "cf-monitord.service"
- "cf-serverd.service"
-)
-md5sums=('06ceba929f4d67e25599cf27d6e45cc0'
+install=${pkgname}.install
+source=("${pkgname}-${pkgver}.tar.gz::http://cfengine.com/source-code/download?file=${pkgname}-${pkgver}.tar.gz"
+ 'cf-execd.service'
+ 'cf-monitord.service'
+ 'cf-serverd.service')
+md5sums=('fa5a5270803fa24e9ab662aae6f73b4a'
'bf64e1dedbcef5a74e3b585076135c87'
'c56bde562ec29c1533433a320f4f4b5d'
'2a3aed38b03b14335a70103e45d42ee8')
@@ -43,22 +27,20 @@ md5sums=('06ceba929f4d67e25599cf27d6e45cc0'
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- # Remove one (or both) of the --with-mysql and/or --with-postgresql
- # lines if you want to reduce dependency chain"
- ./configure \
- --prefix=/usr \
- --with-openssl \
- --with-pcre \
- --without-libvirt \
- --with-libacl=check \
- --with-libxml2 \
- --without-postgresql \
- --without-mysql \
- --with-workdir=/srv/cfengine \
- --with-qdbm \
- --without-tokyocabinet
-
- make
+ ./configure \
+ --prefix=/usr \
+ --with-workdir=/var/lib/${pkgname} \
+ --with-openssl \
+ --with-pcre \
+ --with-libacl=check \
+ --with-libxml2 \
+ --without-libvirt \
+ --with-qdbm \
+ --without-mysql \
+ --without-tokyocabinet \
+ --without-postgresql
+
+ make
}
package() {