summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVanush "Misha" Paturyan2017-05-04 15:18:46 +0100
committerVanush "Misha" Paturyan2017-05-04 15:18:46 +0100
commit1ff13725097b2708784df3b6e420efdfdb028d63 (patch)
tree377b3f0407a7971b252989a2829b30b12752f0eb /PKGBUILD
parent010013116a94b6bac1da907b5c9b79830bedccdf (diff)
downloadaur-1ff13725097b2708784df3b6e420efdfdb028d63.tar.gz
Use openssl-1.0 instead of openssl-1.1
CFEngine fails to build against openssl 1.1. See https://tracker.mender.io/browse/CFE-2629 for an upstream bug report.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27f04bc67dc2..227aaf8e08f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
pkgname=cfengine
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc='Automated suite of programs for configuring and maintaining Unix-like computers.'
url='http://www.cfengine.org'
license=('GPL3')
arch=('i686' 'x86_64')
-depends=('lmdb' 'pcre' 'libxml2' 'pam' 'libyaml' 'curl')
+depends=('lmdb' 'pcre' 'libxml2' 'pam' 'libyaml' 'curl' 'openssl-1.0')
makedepends=('which')
optdepends=('libvirt' 'postgresql-libs' 'libmariadbclient' 'acl')
install=${pkgname}.install
@@ -33,6 +33,8 @@ md5sums=('ae7e2dc8b20faa89089002c9b9fd4e0a'
build() {
cd ${srcdir}/${pkgname}-${pkgver}
+ export CFLAGS=-I/usr/include/openssl-1.0
+ export LDFLAGS=-L/usr/lib/openssl-1.0
./configure \
--prefix=/usr \
--with-workdir=/var/${pkgname} \