summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commitbeab1adb0222fea34905753805686f7592afa08a (patch)
tree1971c057bdcf122a5433ecada89f033b9aea2dc9 /PKGBUILD
downloadaur-beab1adb0222fea34905753805686f7592afa08a.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a6c363e8eb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+# Contributor: Sébastien Luttringer
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Lone_Wolf <lonewolf@xs4all.nl>
+
+pkgname=cfv
+pkgver=1.18.3
+pkgrel=7
+pkgdesc='An utility to both test and create checksum files'
+arch=('any')
+url='http://cfv.sourceforge.net/'
+license=('GPL')
+depends=('python2')
+source=("https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz")
+sha512sums=('dbca82df850703ab68a20db9314475025ac2e7012f34a12abbb358677e81cbb29a465adf4a1b002f6cf1c1dd84f1588fc1072791d6bbaad0c02cc563e5fe7d71')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p 0 << DIFF
+--- cfv
++++ cfv
+@@ -1,3 +1,3 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+
+ # cfv - Command-line File Verify
+DIFF
+}
+
+package() {
+ make -C "$pkgname-$pkgver" install=install PYTHON=python2 prefix=/usr \
+ mandir=/usr/share/man DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: