summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2022-01-09 15:35:29 +0100
committerMichel Zou2022-01-09 15:35:29 +0100
commit7d96a6f83b881bcff4353677e79a9b42fa1527ec (patch)
tree5c9c16ac6b104cb8695981122ae18c2dae585b3a /PKGBUILD
parentfadf013c5a287aa2c241d1dc80b2c80b07f9e0d3 (diff)
downloadaur-7d96a6f83b881bcff4353677e79a9b42fa1527ec.tar.gz
cgal5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c4714c873e3..e19c8e6c80a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
pkgbase=cgal-swig-bindings
pkgname=('python-cgal' 'java-cgal')
-pkgver=r621.a04a496
+pkgver=r765.2479e35
pkgrel=1
pkgdesc='CGAL bindings using SWIG '
arch=('i686' 'x86_64')
license=('custom: Boost')
url="https://github.com/CGAL/cgal-swig-bindings"
-makedepends=('cgal' 'cmake' 'swig3' 'eigen' 'python' 'java-runtime' 'git')
+makedepends=('cgal-headers' 'cmake' 'swig' 'eigen' 'python' 'java-runtime' 'git')
+depends=('tbb' 'boost')
source=("git+https://github.com/CGAL/cgal-swig-bindings.git")
md5sums=('SKIP')
@@ -20,7 +21,7 @@ build()
cd "$srcdir"/cgal-swig-bindings
mkdir -p build && pushd build
cmake \
- -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DSWIG_EXECUTABLE=/usr/bin/swig-3 ..
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
make
ctest -j2 -R python -E polyline_simplification_2 --output-on-failure
}