summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-12-05 19:21:52 +0100
committerMichel Zou2019-12-05 19:21:52 +0100
commitfadf013c5a287aa2c241d1dc80b2c80b07f9e0d3 (patch)
tree1399bd89d0e63d71ffcd1f76c5f5479ea5329686 /PKGBUILD
parentc92c126b691bf574891c9cafa1d733b625584ff4 (diff)
downloadaur-fadf013c5a287aa2c241d1dc80b2c80b07f9e0d3.tar.gz
swig3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93209a35c4c8..4c4714c873e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgbase=cgal-swig-bindings
pkgname=('python-cgal' 'java-cgal')
-pkgver=r560.7850024
+pkgver=r621.a04a496
pkgrel=1
pkgdesc='CGAL bindings using SWIG '
arch=('i686' 'x86_64')
license=('custom: Boost')
url="https://github.com/CGAL/cgal-swig-bindings"
-makedepends=('cgal' 'cmake' 'swig' 'eigen' 'python' 'java-runtime' 'git')
+makedepends=('cgal' 'cmake' 'swig3' 'eigen' 'python' 'java-runtime' 'git')
source=("git+https://github.com/CGAL/cgal-swig-bindings.git")
md5sums=('SKIP')
@@ -20,7 +20,7 @@ build()
cd "$srcdir"/cgal-swig-bindings
mkdir -p build && pushd build
cmake \
- -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DSWIG_EXECUTABLE=/usr/bin/swig-3 ..
make
ctest -j2 -R python -E polyline_simplification_2 --output-on-failure
}