summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFancy Zhang2020-06-21 22:08:11 +0800
committerFancy Zhang2020-06-21 22:08:11 +0800
commit44d838f3bbd9402a31734f34f2a6e118e3ea27d1 (patch)
treeea3f0f448f365e311eb87340282e55845784edac /PKGBUILD
parentaef3613f4b43bffa1ac9b5edd49a0a7652b25b09 (diff)
downloadaur-44d838f3bbd9402a31734f34f2a6e118e3ea27d1.tar.gz
updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afa853d51258..6cf9639aab1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Fancy Zhang <springzfx@gmail.com>
pkgname=cgproxy-git
-pkgver=v0.16.r0.g25d64f7
+pkgver=v0.16.r2.g46fb9ba
pkgrel=1
pkgdesc="A transparent proxy program powered by cgroup2 and tproxy"
arch=('x86_64')
@@ -33,13 +33,13 @@ build(){
git submodule update
# build libexecsnoop.so
- cd "${srcdir}/${pkgname}/execsnoop-libbpf"
- make clean
- make CFLAGS="-O2 -Wall" libexecsnoop.so
+ # cd "${srcdir}/${pkgname}/execsnoop-libbpf"
+ # make clean
+ # make CFLAGS="-O2 -Wall" libexecsnoop.so
# build main binary
cd "${srcdir}/${pkgname}"
- mkdir -p build && cd build && cmake -DCMAKE_BUILD_TYPE=Release .. && make
+ mkdir -p build && cd build && cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/ .. && make
}
package_cgproxy-git(){