summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2023-01-01 14:12:48 +0100
committeraksr2023-01-01 14:12:48 +0100
commit1e46f6962a815d80d2618271552d268bf169cb4c (patch)
tree306a39423b9e2df4100aef8d755ed74e785af4f7 /PKGBUILD
parent6c1b3d4c858472743db5f8cf1e752b1fe3b46508 (diff)
downloadaur-1e46f6962a815d80d2618271552d268bf169cb4c.tar.gz
Fix source and build.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64a1bd3384e6..6f35bc52c8d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,26 @@
_pkgname=cgrep
pkgname=$_pkgname-belllabs
pkgver=8.15
-pkgrel=1
-pkgdesc="Provides many of the features of grep, egrep, and fgrep with greatly enhanced performance."
+pkgrel=2
+pkgdesc='Provides many of the features of grep, egrep, and fgrep with greatly enhanced performance.'
arch=('i686' 'x86_64')
-url="https://www.bell-labs.com/project/wwexptools/cgrep/"
-url="http://sourceforge.net/projects/cgrep/"
+url='http://sourceforge.net/projects/cgrep/'
license=('GPL')
depends=('ncurses')
makedepends=('gcc' 'make')
-source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz")
+source=("https://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz")
md5sums=('7d9f15e9026d075ada9d48bc0c158941')
sha1sums=('89b367fb0f321aac1897e2d9192a49ceb4ebe8fe')
sha256sums=('cd73be8860211cb121656c22400d6007950bdab63e96b9872d4e4dcc11f8202e')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "$srcdir/$_pkgname-$pkgver"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- make DESTDIR=$pkgdir install
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
}
-