summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2016-03-23 07:10:26 +0100
committeraksr2016-03-23 07:10:26 +0100
commit6c1b3d4c858472743db5f8cf1e752b1fe3b46508 (patch)
tree41e3f0015bdee4128eb468c64a32d022128550c5 /PKGBUILD
downloadaur-6c1b3d4c858472743db5f8cf1e752b1fe3b46508.tar.gz
Start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64a1bd3384e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Nathan Owe <ndowens04 at gmail>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Maintainer: aksr <aksr at t-com dot me>
+_pkgname=cgrep
+pkgname=$_pkgname-belllabs
+pkgver=8.15
+pkgrel=1
+pkgdesc="Provides many of the features of grep, egrep, and fgrep with greatly enhanced performance."
+arch=('i686' 'x86_64')
+url="https://www.bell-labs.com/project/wwexptools/cgrep/"
+url="http://sourceforge.net/projects/cgrep/"
+license=('GPL')
+depends=('ncurses')
+makedepends=('gcc' 'make')
+source=("http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('7d9f15e9026d075ada9d48bc0c158941')
+sha1sums=('89b367fb0f321aac1897e2d9192a49ceb4ebe8fe')
+sha256sums=('cd73be8860211cb121656c22400d6007950bdab63e96b9872d4e4dcc11f8202e')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}
+