summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:16:37 +0200
committerAlexander F Rødseth2015-06-10 15:16:37 +0200
commit487a231df194ea764beb363adb53014a567a37d8 (patch)
treeb0421d30e700bf929afed4c6c2ba7586a2d5e9d8 /PKGBUILD
downloadaur-487a231df194ea764beb363adb53014a567a37d8.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c2cfefd0f90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=cgvg
+pkgver=1.6.3
+pkgrel=1
+pkgdesc='Commandline tools for searching and browsing sourcecode'
+arch=('any')
+url='http://uzix.org/cgvg.html'
+depends=('perl-perl4-corelibs')
+license=('GPL')
+source=("http://www.uzix.net/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('d879f541abcc988841a8d86f0c0781ded6e70498a63c9befdd52baf4649a12f3')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: