summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-09-30 15:53:23 +1300
committercaltlgin2020-09-30 15:53:23 +1300
commitbd047f6ba9b975de8e5950bbcdca328f3387bcc2 (patch)
treec9fcb6250fd2244e595487a2ba631fb67f0e97a4 /PKGBUILD
parentd778c7e4e7d629f1b9548f8a7367888abcfdb04d (diff)
downloadaur-chaos-client.tar.gz
Add "go clean -modcache"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a08e0ae962d0..b2c52d92afff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname=chaos
+_pkgname='chaos'
pkgname="${_pkgname}-client"
pkgver=0.1.6
pkgrel=1
pkgdesc='Client to communicate with Chaos DNS API'
-arch=('x86_64')
+arch=('x86_64' 'armv6h' 'aarch64')
url='https://github.com/projectdiscovery/chaos-client'
license=('MIT')
makedepends=('go')
@@ -13,13 +13,17 @@ provides=("${_pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('6d8a848c015a39dd7258eab429d263d3c3ab0dff7a705418f3c18e9a90ea689b')
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- export GOPATH="${srcdir}"
cd "${pkgname}-${pkgver}"
go build -v -o "${_pkgname}" ."/cmd/${_pkgname}"