summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:21:25 -0400
committerbrent s2015-08-24 21:21:25 -0400
commit883b469432581e2cc5e8d8d93c7e329ae4435b97 (patch)
treefc24c7f3d663845458e9b8534bd010296d35beaa /PKGBUILD
downloadaur-883b469432581e2cc5e8d8d93c7e329ae4435b97.tar.gz
initial import from AUR3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c5cc9602380
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: onny <onny@project-insanity.org>
+# Contributor: onny <onny@project-insanity.org>
+
+pkgname=chapcrack-git
+pkgver=ae2827f
+pkgrel=2
+pkgdesc="A tool for parsing and decrypting MS-CHAPv2 network handshakes."
+arch=('i686' 'x86_64')
+url="https://github.com/moxie0/chapcrack"
+license="GPL3"
+depends=('python2' 'python2-dpkt' 'python2-m2crypto' 'python2-passlib' 'python2-m2crypto')
+source=('git+https://github.com/moxie0/chapcrack.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$SRCDEST/chapcrack"
+ git describe --always | sed 's|-|.|g'
+}
+build() {
+ cd "$srcdir/chapcrack"
+ python2 setup.py build
+}
+package () {
+ cd "${srcdir}/chapcrack"
+ python2 setup.py install --root=${pkgdir}
+}
+