summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorghbrown2024-03-21 13:11:23 -0500
committerghbrown2024-03-21 13:11:23 -0500
commit6b862cb06289da2376a40af27aa31901cfb0401b (patch)
treeb5f52ec6c27eb3758aa68fffd9d9d245766f6cbc /PKGBUILD
parentc6851afc497346f2e1a729f32015c0bb2e918fe5 (diff)
downloadaur-6b862cb06289da2376a40af27aa31901cfb0401b.tar.gz
Resolve issues in out-of-date flag; turn off some options for build to work
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index baba735eb70b..eb6f32ba13df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,12 @@ pkgdesc="Programming language designed for productive parallel computing at scal
url="https://chapel-lang.org/"
arch=('x86_64' 'arm')
license=('Apache')
+provides=("${_gitname}")
+conflicts=("${_gitname}")
# depends=('python' 'perl' 'llvm' 'clang')
-depends=('python' 'perl' 'llvm15' 'llvm15-libs' 'clang15') # if using old versions
+depends=('python' 'perl' 'llvm16' 'llvm16-libs' 'clang16') # if using old versions
makedepends=('git' 'cmake')
+options=('!debug' '!lto') # build currently fails from default flags these add
source=("git+https://github.com/${_gituser}/${_gitname}.git")
sha256sums=('SKIP') # source is not static
@@ -44,8 +47,8 @@ build() {
# if depending on old versions like llvmXX and clangXX
export CHPL_TARGET_CPU="native"
export CHPL_HOST_COMPILER="clang"
- export CHPL_HOST_CC="/usr/lib/llvm15/bin/clang"
- export CHPL_HOST_CXX="/usr/lib/llvm15/bin/clang++"
+ export CHPL_HOST_CC="/usr/lib/llvm16/bin/clang"
+ export CHPL_HOST_CXX="/usr/lib/llvm16/bin/clang++"
./configure --prefix=/usr
make
}