summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWesley Moore2020-03-22 18:12:12 +1100
committerWesley Moore2020-03-22 18:12:12 +1100
commitafbf3748ffd70534fe5802a9629db56de0eeb362 (patch)
treebe0e3072703e5a05ac436e5c781efdf33317e97e /PKGBUILD
parenteb2f6db85963883bfdcea5191c1c0af3cc6b0afe (diff)
downloadaur-afbf3748ffd70534fe5802a9629db56de0eeb362.tar.gz
Version 0.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c106c1de213f..6113552775e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Wesley Moore <wes@wezm.net>
pkgname=chars
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
pkgdesc='Command line tool to display information about unicode characters.'
arch=('i686' 'x86_64')
@@ -8,15 +8,16 @@ url="https://github.com/antifuchs/chars"
license=('MIT')
depends=()
conflicts=('chars-git')
-makedepends=('rust' 'cargo' 'git')
+makedepends=('cargo')
source=("$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7816cb435c9c2977ae704c6176e97ce4f5a7bb40621aaf9c5104598c29277b77')
+sha256sums=('5e2807b32bd75862d8b155fa774db26b649529b62da26a74e817bec5a26e1d7c')
build() {
cd "$pkgname-$pkgver"
- /usr/bin/cargo build --release
+ /usr/bin/cargo build --release --locked
}
package() {
- install -Dm755 "$srcdir/$pkgname-$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$srcdir/$pkgname-$pkgver/target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}