summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPromiSe####2020-10-18 22:02:15 +0300
committerPromiSe####2020-10-18 22:02:15 +0300
commit3ea21f23c8efa49d431fc70f96a3208bef66fc5d (patch)
treef11a3223235c2ee85a381d3ec9165986452f543f /PKGBUILD
parent28240ce9f0b4b190c80d3ba57561c5bf652d7b88 (diff)
downloadaur-3ea21f23c8efa49d431fc70f96a3208bef66fc5d.tar.gz
Префикс
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39a36c7b327c..9ea42ee4de43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chatrullete-plus
pkgver=0.0.2
-pkgrel=7
+pkgrel=8
pkgdesc="ChatRullete (Plus)"
arch=('x86_64')
url="https://github.com/chatrullete-plus"
@@ -22,8 +22,6 @@ package() {
mv "${srcdir}/"* "${pkgdir}/usr/lib/chatrullete"
mv "${pkgdir}/usr/lib/chatrullete/ChatRullete" "${pkgdir}/usr/lib/chatrullete/chatrullete"
- # Create symlink to executable
- ln -s "${pkgdir}/usr/lib/chatrullete/chatrullete" "${pkgdir}/usr/bin/chatrullete"
# Copy resources
cp "${startdir}/chatrullete.desktop" "${pkgdir}/usr/share/applications"
@@ -31,5 +29,22 @@ package() {
# Permission fix
chmod +x "${pkgdir}/usr/lib/chatrullete/chatrullete"
- chmod +x "${pkgdir}/usr/bin/chatrullete"
+}
+
+post_install() {
+ echo "Hello!"
+
+ # Create symlink to executable
+ ln -s "/usr/lib/chatrullete/chatrullete" "/usr/bin/chatrullete"
+
+ # Permission fix
+ chmod +x "/usr/bin/chatrullete"
+}
+
+post_remove() {
+ echo "Good by!"
+
+ if [ -f "/usr/bin/chatrullete" ]; then
+ rm "/usr/bin/chatrullete"
+ fi
} \ No newline at end of file