summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzneix2022-05-11 23:40:56 +0200
committerzneix2022-05-11 23:40:56 +0200
commit9d136722c7ab50895e3a84a70e4969e57cad5ba6 (patch)
tree10ac1c85145fe8de1612ae0509d2e7d1824d22ea /PKGBUILD
parent5acc96c6d450fcaee8732c3cc587ded1a90e96a1 (diff)
downloadaur-9d136722c7ab50895e3a84a70e4969e57cad5ba6.tar.gz
Add git submodules
Add missing cmake-sanitizers Add new magic_enum - see note in PKGBUILD (taken from upstream package, since it's the exact same situation as there)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f05699909b5..0504f6bc3821 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chatterino2-7tv-git
_pkgname=chatterino7
-pkgver=r3487.dbd99e4c
+pkgver=r3610.d2e9c105
pkgrel=1
pkgdesc='A fork of Chatterino2 with built-in support for 7tv emotes'
arch=('any')
@@ -25,7 +25,9 @@ source=("git+https://github.com/SevenTV/chatterino7"
"git+https://github.com/pajlada/serialize"
"git+https://github.com/Tencent/rapidjson"
"git+https://github.com/Chatterino/qtkeychain"
- "git+https://github.com/zaphoyd/websocketpp")
+ "git+https://github.com/zaphoyd/websocketpp"
+ "git+https://github.com/arsenm/sanitizers-cmake"
+ "git+https://github.com/Neargye/magic_enum")
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -35,6 +37,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -54,6 +58,9 @@ prepare () {
git config submodule.rapidjson $srcdir/$_pkgname/lib/rapidjson
git config submodule.qtkeychain $srcdir/$_pkgname/lib/qtkeychain
git config submodule.websocketpp $srcdir/$_pkgname/lib/websocketpp
+ git config submodule.sanitizers-cmake $srcdir/$_pkgname/lib/sanitizers-cmake
+ # We can't set the local directory of this submodule as we have no way of accessing the config name `submodule.magic_enum` because underscores are actually not allowed.
+ #git config submodule.magic_enum $srcdir/$_pkgname/lib/magic_enum
git submodule update
}