summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorckath2018-08-19 16:07:59 +0200
committerckath2018-08-19 16:07:59 +0200
commit87eb119f043a4e7f48de3205dfabdcabc4759e70 (patch)
tree9faf20c477e15385e0718984018c76da7d57739c /PKGBUILD
parent6096f514695d63aff83c9c45560e79ce76e8f096 (diff)
downloadaur-87eb119f043a4e7f48de3205dfabdcabc4759e70.tar.gz
added streamlink optdep and fixed versioning
for now the version has been reverted to the old way of just taking the commit hash, if later a stable tag format is established or a better way of incorporating tags into version is found it'll be switched to that. but this will at least stop it from incorrectly assuming version on aur is always newer than local.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 065476396443..95317b00da2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=chatterino2
pkgname="$_name-git"
-pkgver=nightly.win.r39.ge23ce31
+pkgver=r1503.8bcc9c48
pkgrel=1
pkgdesc='Chatterino 2 is the second installment of the Twitch chat client series "Chatterino". dev/git version.'
arch=('any')
@@ -12,16 +12,14 @@ install=$pkgname.install
provides=("${_name%2}")
conflicts=("${_name%2}")
depends=('rapidjson' 'gst-plugins-ugly' 'gst-plugins-good' 'qt5-multimedia' 'qt5-base' 'qt5-svg' 'pulseaudio')
+optdepends=('streamlink: For piping streams to video players')
makedepends=('boost' 'git')
source=("${_name%2}.png" "${_name%2}.desktop" "git://github.com/fourtf/$_name")
sha1sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_name"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare () {