summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Brost2017-11-03 12:55:13 +0100
committerJulian Brost2017-11-03 12:55:13 +0100
commitb20a4d407febe3aea946a364c0dc69fde0f62c83 (patch)
treeac212b4d61a5368cd30cb446180f1d164636277b /PKGBUILD
downloadaur-b20a4d407febe3aea946a364c0dc69fde0f62c83.tar.gz
Initial version 6.4.1.6-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ccbe6703919
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Julian Brost <julian@0x4a42.net>
+
+pkgname=check-nwc-health
+pkgver=6.4.1.6
+pkgrel=1
+pkgdesc="Monitoring check for various network equipment"
+arch=('any')
+url='https://labs.consol.de/nagios/check_nwc_health/'
+license=('GPL')
+depends=('perl')
+makedepends=()
+optdepends=('perl-soap-lite: checks based on UPnP'
+ 'perl-xml-libxml: checks based on UPnP'
+ 'perl-xml-treebuilder: FritzBox checks'
+ 'perl-json: FritzBox checks')
+source=("https://labs.consol.de/assets/downloads/nagios/check_nwc_health-$pkgver.tar.gz")
+sha256sums=('97345b575687f649699abb80aea680e5a744bf91702bcade1a25cd036a07e815')
+
+build() {
+ cd "check_nwc_health-$pkgver"
+ ./configure --prefix=/usr --libexecdir=/usr/lib/monitoring-plugins
+ make
+}
+
+package() {
+ cd "check_nwc_health-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}