summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeoffrey “Frogeye” Preud'homme2019-06-05 22:20:06 +0200
committerGeoffrey “Frogeye” Preud'homme2019-06-05 22:20:06 +0200
commit774159cc4c42960df3341aed9c208f040353f40d (patch)
tree2575264f4d2fc47336e559ffc9c5d744dba513e8 /PKGBUILD
parent0e08fbe8d6488245d3b0c8d4beced812495ce775 (diff)
downloadaur-check-sieve.tar.gz
Update to 0.6 + PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 6 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fe13813348b..66c6116ccfb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,24 @@
# Maintainer: Geoffrey Frogeye <geoffrey+aur@frogeye.fr>
pkgname=check-sieve
-pkgver=0.5
-_gitver=2219f6fb48caf2d975f8843dc421c399e27d9e6d
+pkgver=0.6
pkgrel=1
pkgdesc="Syntax checker for mail sieves."
arch=('i686' 'x86_64')
url="https://github.com/dburkart/${pkgname}"
license=('custom')
-groups=()
-depends=()
-makedepends=('git' 'gcc' 'make' 'bison' 'flex')
-optdepends=()
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-replaces=("${pkgname}")
-backup=()
-options=()
-install=
-changelog=
-source=("${pkgname}::git+https://github.com/dburkart/${pkgname}.git#commit=${_gitver}")
-noextract=()
-md5sums=('SKIP')
+depends=('gcc-libs')
+source=("https://github.com/dburkart/check-sieve/archive/${pkgname}-${pkgver}.tar.gz")
+md5sums=('63345f1bc9afb1e54e335f8a99cdfad4')
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make
}
-#check() {
-# cd "${srcdir}/${pkgname}"
-# make test
-#}
-
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
install -Dm755 check-sieve "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}