summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeoffrey Frogeye2015-09-06 17:00:45 +0200
committerGeoffrey Frogeye2015-09-06 17:00:45 +0200
commit4adb496cc5212722d09ea087234002aa83d76ac7 (patch)
tree5485e4eb28426dabdee0b09fd9f4ab7ee12637e9 /PKGBUILD
downloadaur-4adb496cc5212722d09ea087234002aa83d76ac7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1912c203efc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Geoffrey Frogeye <geoffrey+aur@frogeye.fr>
+
+pkgname=check-sieve
+pkgver=0.3
+_gitver=682d96738d26291b76a908b094d125877d30e1a2
+pkgrel=1
+pkgdesc="Syntax checker for mail sieves."
+arch=('i686' 'x86_64')
+url="https://github.com/dburkart/${pkgname}"
+license=('custom')
+groups=()
+depends=()
+makedepends=('git' 'gcc' 'make' 'bison' 'flex')
+optdepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=("${pkgname}")
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/dburkart/${pkgname}.git#commit=${_gitver}")
+noextract=()
+md5sums=('SKIP')
+
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+#check() {
+# cd "${srcdir}/${pkgname}"
+# make test
+#}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 check-sieve "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+