summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2022-08-02 16:10:46 -0400
committerDavid Parrish2022-08-02 16:10:46 -0400
commit862438af9776a695e9abe5573db38f0562642fe9 (patch)
treeed47372ee2c5fdc7051dca638186585d0fe1467a /PKGBUILD
parentf6cb7eb433962eccbeedee40310b1cd74ef41ac1 (diff)
downloadaur-check_smartmon-git.tar.gz
Switch to a python3 fork which is better maintained
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5eae52ae029d..97afd8d569f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=check_smartmon-git
-pkgver=r31.07b14b8
+pkgver=r43.66ec3f3
pkgrel=1
pkgdesc="Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature."
arch=('any')
-url="https://github.com/nihlaeth/Nagios_check_smartmon"
+url="https://github.com/driehuis/Nagios_check_smartmon"
license=('GPL2')
-depends=('python2-psutil' 'smartmontools')
+depends=('python-psutil' 'smartmontools')
makedepends=('git')
-source=("${pkgname}::git+https://github.com/nihlaeth/Nagios_check_smartmon.git")
+source=("${pkgname}::git+https://github.com/driehuis/Nagios_check_smartmon.git")
sha256sums=("SKIP")
pkgver() {
@@ -17,12 +17,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname" || exit 1
- # Fixing Python version
- find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
-}
-
package() {
# Install License
install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"