summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2016-09-07 20:36:39 -0400
committerDavid Parrish2016-09-07 20:36:39 -0400
commit8cb1a989fa178c6fadf018a581dd2b21b962b863 (patch)
treecdd5d04dd106b715c20be8f98a482f1d7efc8c8a /PKGBUILD
downloadaur-8cb1a989fa178c6fadf018a581dd2b21b962b863.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98df0b277081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=check_smartmon-git
+pkgver=r25.c1569c3
+pkgrel=1
+pkgdesc="Nagios-Plugin that uses smartmontools (http://smartmontools.sourceforge.net/) to check disk health status and temperature."
+arch=('i686' 'x86_64')
+url="https://github.com/nihlaeth/Nagios_check_smartmon"
+license=('GPL2')
+depends=('python2' 'python2-psutil')
+source=("${pkgname}::git+https://github.com/nihlaeth/Nagios_check_smartmon.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python$#/usr/bin/python2#g'
+}
+
+package() {
+ # Install License
+ install -Dm644 "$pkgname/LICENCE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Put code files into '/usr/share'
+ install -Dm755 "$pkgname/check_smartmon.py" "$pkgdir/usr/share/check_smartmon/check_smartmon.py"
+
+ # Install binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/check_smartmon/check_smartmon.py" "${pkgdir}/usr/bin/check_smartmon"
+}