summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrevor Bramble2018-07-06 10:33:08 -0700
committerTrevor Bramble2018-07-06 10:33:08 -0700
commitcc8aaee67b7961398a0d07d6aa5e38ea3a0f785f (patch)
tree19e707fc451a7a73da43945aafe1355a189303c8 /PKGBUILD
parentcf3de1952d91702cea2f043933232640a80bf154 (diff)
downloadaur-cc8aaee67b7961398a0d07d6aa5e38ea3a0f785f.tar.gz
Update version: 3.0.36 → 3.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 898cd28eea69..51a35987bfe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,16 @@
# Maintainer: Trevor Bramble <inbox@trevorbramble.com>
pkgname=chef-dk
-pkgver=3.0.36
+pkgver=3.1.0
pkgrel=1
-_ubuntuver=raring
-_ubunturel=4
-pkgdesc="The Chef Development Kit contains everything you need to start using Chef along with the tools essential to managing the code that runs your business."
+pkgdesc="The Chef development kit contains all the tools you need to develop and test your infrastructure, built by the awesome Chef community."
arch=('x86_64')
url="https://downloads.chef.io/chef-dk/"
license=('Apache')
depends=()
-conflicts=( chef chef-solo chef-client )
-source=("https://packages.chef.io/files/stable/chefdk/${pkgver}/debian/8/chefdk_${pkgver}-1_amd64.deb")
-sha512sums=('6aa91ceafebafab48b2e33bc0957047d18c4bcc61f90fd7cd08e55fccb2d09544e699bcda2f59a57190f60a790d30bd7ccf06f28ac7f37ecbfac2137f5e63f7b')
+conflicts=( chef chef-solo chef-client chef-workstation )
+source=("https://packages.chef.io/files/stable/chefdk/${pkgver}/debian/9/chefdk_${pkgver}-1_amd64.deb")
+sha512sums=('c46c01a6e4e8010671b554648c0d844310b443e5825f1a0054b1889dc7cc8353293c97a8c7ec8df2ad2d1c303fd139d767ab424692de12c4ac46c33af889aa2d')
package() {
cd "$srcdir"
@@ -22,7 +20,7 @@ package() {
find $pkgdir -type d -name ".git" | xargs rm -rf
# link executables
- binaries="berks chef chef-apply chef-shell chef-solo chef-zero delivery fauxhai foodcritic kitchen knife ohai push-apply pushy-client pushy-service-manager rubocop cookstyle chef-client"
+ binaries="berks chef chef-apply chef-shell chef-solo chef-vault cookstyle dco delivery foodcritic inspec kitchen knife ohai push-apply pushy-client pushy-service-manager chef-client"
mkdir -p $pkgdir/usr/bin