summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormarin2018-12-09 21:30:00 +0100
committermarin2018-12-09 21:30:00 +0100
commit33895967091201c622d860b1e46384f00337eb83 (patch)
tree2120cb4dcbcd1e9c9e4f1210f6486f60a6ef5c34 /PKGBUILD
downloadaur-33895967091201c622d860b1e46384f00337eb83.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34af35b11bba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# maintainer : marin <turquoise.hexagon@protonmail.com>
+
+pkgname=cherry-font-git
+pkgver=1.0
+pkgrel=1
+pkgdesc='cherry, yet another bitmap font'
+url=https://github.com/turquoise-hexagon/cherry
+source=("$pkgname::git+https://github.com/turquoise-hexagon/cherry")
+licence=('MIT')
+arch=('any')
+makedepends=('git' 'xorg-font-utils')
+install="$pkgname.install"
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+build ()
+{
+ cd "$srcdir/$pkgname" || exit
+
+ for b in *.bdf; do
+ bdftopcf -o "${b/.bdf/.pcf}" "$b"
+ done
+}
+
+package ()
+{
+ cd "$srcdir/$pkgname" || exit
+
+ install -d -m755 "$pkgdir/usr/share/fonts/misc"
+ install -D -m644 *.pcf "$pkgdir/usr/share/fonts/misc"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licences/$pkgname/LICENSE"
+}