summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFanch2018-11-27 00:01:53 +0100
committerFanch2018-11-27 00:01:53 +0100
commitdd2a9546625203b306f99daad38e6e36e07cc7db (patch)
tree2e27d13b2e648f138d85c9e0195751c2eb0a3b08 /PKGBUILD
downloadaur-dd2a9546625203b306f99daad38e6e36e07cc7db.tar.gz
Update Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1aff93aea511
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=chevereto
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Chevereto is an image hosting script that allows you to create a beautiful and full-featured image hosting website on your own server."
+arch=(any)
+url="https://chevereto.com/free"
+license=("GPL")
+depends=("php" "php-gd" "mariadb")
+install=chevereto.install
+options=(emptydirs)
+
+source=(https://github.com/Chevereto/Chevereto-Free/archive/${pkgver}.tar.gz
+ chevereto.perm.sh)
+md5sums=('694fa397ea504e8eb018c5b8392a7c84'
+ 'e7add39512c475948c6709a0a6a9c309')
+
+
+
+package() {
+
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -a Chevereto-Free-$pkgver "${pkgdir}/usr/share/webapps/chevereto"
+
+ install -D -m755 "${srcdir}/chevereto.perm.sh" "${pkgdir}/usr/bin/set-chevereto-perm"
+}