summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordgeibi2019-05-11 00:39:44 +0800
committerdgeibi2019-05-11 00:39:44 +0800
commit477911389e8b2cfd065a795defcd1e6609ff4690 (patch)
treecfd3a40573f1cdda7820365b51324e20922a3fa8 /PKGBUILD
parent5a8c8386d7c775cfead1464d10b8b082ab701748 (diff)
downloadaur-477911389e8b2cfd065a795defcd1e6609ff4690.tar.gz
thank taekyung and bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 7 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index baf626c4e13b..e7da17d4180b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Xavier Peng <png.inside@gmail.com>
pkgname=chez-scheme
-pkgver=9.5
-pkgrel=2
+pkgver=9.5.2
+pkgrel=1
pkgdesc="Chez Scheme is a compiler and run-time system for the language of the Revised^6 Report on Scheme (R6RS), with numerous extensions."
arch=(i686 x86_64)
url="https://github.com/cisco/ChezScheme"
@@ -11,24 +11,16 @@ license=('APL')
makedepends=('binutils' 'make' 'ncurses' 'libx11' 'xproto')
conflicts=('petite-chez-scheme' 'chez-scheme-git')
replaces=('petite-chez-scheme' 'chez-scheme-git')
-source=("https://github.com/cisco/ChezScheme/releases/download/v9.5/csv9.5.tar.gz")
-sha1sums=('fcbda13bb61643209fd5d825e393d2064dc6c5be')
+source=("https://github.com/cisco/ChezScheme/releases/download/v$pkgver/csv$pkgver.tar.gz")
+sha1sums=('2d07be6aa99e66365864d96f538e12d3c5098957')
_archivename=csv$pkgver
-prepare() {
- cd "$srcdir/${_archivename}" || exit
- # copy from Jonathon Fernyhough, glibc=2.26 dropped xlocale.h, this is a hacky workaround
- cp /usr/include/locale.h zlib/xlocale.h
-}
-
build() {
- cd "$srcdir/${_archivename}" || exit
- unset CHEZSCHEMELIBDIRS
- LDFLAGS="-ltinfo" ./configure --installprefix=/usr --temproot=$pkgdir
- make
+ cd "$srcdir/${_archivename}"
+ ./configure --installprefix=/usr --temproot=$pkgdir
}
package() {
- cd "${srcdir}/${_archivename}" || exit
+ cd "${srcdir}/${_archivename}"
make install DESTDIR="$pkgdir"
}