summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas E. Hansen2024-02-07 10:15:05 +0000
committerThomas E. Hansen2024-02-07 10:15:05 +0000
commit4c55192a3ecaf24889e413689d3213bc899165d4 (patch)
tree7a9513f3fb55ccd2286910d4d315e3479afe4e61 /PKGBUILD
parent6d960bea1656bb372413b9d1bd58d124b8bfea2e (diff)
downloadaur-4c55192a3ecaf24889e413689d3213bc899165d4.tar.gz
Update to version 10.0.0
Chez Scheme now officially supports aarch64! Full list of changes for this major release can be found at: https://cisco.github.io/ChezScheme/release_notes/v10.0/release_notes.html
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08f9b13861cf..f2c234c3b89a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
# Maintainer: Thomas Hansen <thomas-e-hansen@teh6.eu>
pkgname=chez-scheme
-pkgver=9.6.4
+pkgver=10.0.0
pkgrel=1
pkgdesc="Compiler and run-time system for the language of the Revised^6 Report on Scheme (R6RS), with numerous extensions."
-arch=(i686 x86_64)
+arch=(i686 x86_64 aarch64)
url="https://github.com/cisco/ChezScheme"
depends=()
license=('Apache')
@@ -15,12 +15,13 @@ depends=('ncurses' 'libx11' 'libutil-linux')
conflicts=('petite-chez-scheme' 'chez-scheme-git')
replaces=('petite-chez-scheme' 'chez-scheme-git')
source=("https://github.com/cisco/ChezScheme/releases/download/v$pkgver/csv$pkgver.tar.gz")
-sha256sums=('f5827682fa259c47975ffe078785fb561e4a5c54f764331ef66c32132843685d')
+sha256sums=('d37199012b5ed1985c4069d6a87ff18e5e1f5a2df27e402991faf45dc4f2232c')
_archivename=csv$pkgver
build() {
cd "$srcdir/${_archivename}"
./configure --installprefix=/usr --temproot=$pkgdir --threads --installschemename=chez --installscriptname=chez-script
+ make
}
package() {