summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordgeibi2016-05-22 21:57:34 +0800
committerdgeibi2016-05-22 21:57:34 +0800
commit8bb73a0dacbaa6c3e31a4c88afe7902e3fae6c6d (patch)
treeb69711e50267f7bcd1e3b59752d14fa1cc2d8e1c /PKGBUILD
downloadaur-8bb73a0dacbaa6c3e31a4c88afe7902e3fae6c6d.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b7ff4ca6efa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Xavier Peng <png.inside@gmail.com>
+
+pkgname=chez-scheme
+pkgver=9.4
+pkgrel=1
+pkgdesc="Chez Scheme is an implementation of the Revised6 Report on Scheme [27] (R6RS) with numerous language and programming environment extensions. (threaded build)"
+arch=(i686 x86_64)
+url="https://github.com/cisco/ChezScheme"
+depends=()
+license=('APL')
+makedepends=('binutils' 'make' 'git' 'ncurses' 'libx11' 'xproto')
+conflicts=('petite-chez-scheme' 'chez-scheme-git')
+replaces=('petite-chez-scheme' 'chez-scheme-git')
+source=("$url/archive/v${pkgver}.tar.gz")
+sha1sums=('SKIP')
+_archivename=ChezScheme-$pkgver
+
+pkgver() {
+ git ls-remote -t https://github.com/cisco/ChezScheme | tail -1 | sed 's|.*refs/tags/v||'
+}
+
+build() {
+ cd "$srcdir/${_archivename}" || exit
+ git init
+ rm -rf nanopass/ stex/ zlib/
+ git submodule add git@github.com:nanopass/nanopass-framework-scheme.git nanopass
+ git submodule add git@github.com:dybvig/stex.git stex
+ git submodule add git@github.com:madler/zlib.git zlib
+ ./configure --installprefix=/usr --temproot=$pkgdir
+ make
+}
+
+package() {
+ cd "${srcdir}/${_archivename}" || exit
+ make install DESTDIR="$pkgdir"
+}