summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArcturusB2017-05-22 14:06:09 +0200
committerArcturusB2017-05-22 14:06:09 +0200
commit68c90677d8f5e8d778730e6032c2fc66921e2050 (patch)
treec7686e6e52f81d35cdee76c5baa90346e0d45c78 /PKGBUILD
downloadaur-chiantipy-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ed5425360a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gabriel "ArcturusB" Perouze" <arcturus@openmailbox.org>
+
+pkgname=chiantipy-git
+_gitname=ChiantiPy
+pkgver=0.7.dev
+pkgrel=1
+pkgdesc="A python package to calculate the radiative properties of astrophysical plasmas based on the CHIANTI atomic database"
+arch=('i686' 'x86_64')
+url="https://github.com/chianti-atomic/ChiantiPy"
+license=('ISC')
+depends=('python'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-matplotlib'
+ 'ipython-ipyparallel')
+optdepends=('ipython: interactive terminal'
+ 'python-pyqt4: GUI'
+ 'wxpython: GUI alternative')
+makedepends=('git')
+provides=(chiantipy)
+conflicts=(chiantipy)
+options=(!emptydirs)
+install=
+source=(git+https://github.com/chianti-atomic/ChiantiPy.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "%s%s" "$(grep "VERSION = " setup.py | cut -d\' -f2)" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${_gitname}"
+ git submodule update --init
+ python setup.py install --root="${pkgdir}"
+}
+
+post_install() {
+ echo "In order to use ChiantiPy, download the CHIANTI database:"
+ echo " http://www.chiantidatabase.org/chianti_download.html"
+ echo "Assuming you've placed the CHIANTI tree in $HOME, set the environment"
+ echo "variable in your .bashrc file:"
+ echo " export XUVTOP=$HOME/chianti/dbase"
+}
+
+# vim:set ts=2 sw=2 et: