summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJunker2024-01-02 22:21:04 +0700
committerJunker2024-01-02 22:21:04 +0700
commitcd0624ba812480a002f19f3a00abdfd56b28a357 (patch)
treecfef72ee284f93ebd61ed6539b70397304cd6a56 /PKGBUILD
downloadaur-cd0624ba812480a002f19f3a00abdfd56b28a357.tar.gz
main commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ab3d22882ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=chicken-address-info
+_name=address-info
+pkgver=1.0.5
+pkgrel=1
+pkgdesc='Network address information access for Chicken Scheme'
+arch=('x86_64')
+license=('BSD')
+depends=("chicken" "chicken-srfi-1")
+url='http://wiki.call-cc.org/eggref/5/address-info'
+
+build() {
+ CHICKEN_INSTALL_REPOSITORY=${srcdir} CHICKEN_INSTALL_PREFIX=${srcdir} chicken-install -no-install-dependencies $_name:$pkgver
+}
+package() {
+ install -d ${pkgdir}/usr/lib/chicken/11
+ find ${srcdir} -maxdepth 1 -type f -exec cp -t ${pkgdir}/usr/lib/chicken/11 {} +
+}
+