summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJunker2024-01-02 22:33:45 +0700
committerJunker2024-01-02 22:33:45 +0700
commitf268ceb1f1affa1d0a807455c17e8194a99a3ee2 (patch)
tree5db90e03d5a19abbe273c5731b614d3026892c58 /PKGBUILD
parent54366f386bca9b141973200069724f532b79014e (diff)
downloadaur-chicken-condition-utils.tar.gz
main commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48fc3b06b6e7..0c79e2fcee02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,18 @@
-# Maintainer: Aaron P <aaronbpaden@gmail.com>
-# Contributer: Jim Pryor <profjim@jimpryor.net>
-
pkgname=chicken-condition-utils
-_pkgname=condition-utils
-pkgver=1.1.1
+_name=condition-utils
+pkgver=2.2.3
pkgrel=1
-pkgdesc="Chicken Scheme Egg: SRFI 12 Condition Utilities"
-arch=('i686' 'x86_64')
-url="http://chicken.wiki.br/eggref/4/condition-utils"
+pkgdesc='SRFI 12 Condition Utilities for Chicken Scheme'
+arch=('x86_64')
license=('BSD')
-depends=('chicken>=4.5.0' 'chicken-setup-helper' 'chicken-check-errors>=1.12.0' )
+depends=("chicken" "chicken-srfi-1" "chicken-srfi-69" "chicken-check-errors")
+url='http://wiki.call-cc.org/eggref/5/condition-utils'
build() {
- cd "$srcdir/"
- chicken-install -r "${_pkgname}":"${pkgver}"
+ CHICKEN_INSTALL_REPOSITORY=${srcdir} CHICKEN_INSTALL_PREFIX=${srcdir} chicken-install -no-install-dependencies $_name:$pkgver
}
-
package() {
- cd "$_pkgname"
- chicken-install -p "$pkgdir/usr"
+ install -d ${pkgdir}/usr/lib/chicken/11
+ find ${srcdir} -maxdepth 1 -type f -exec cp -t ${pkgdir}/usr/lib/chicken/11 {} +
}
+